We are continuing to verify the maintenance items.
Posted Aug 21, 2025 - 14:00 PDT
Verifying
Verification is currently underway for the maintenance items.
Posted Aug 21, 2025 - 12:35 PDT
Update
Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Aug 21, 2025 - 12:30 PDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 21, 2025 - 12:00 PDT
Scheduled
We will be performing some server maintenance and upgrades. During this time the btwb app, website, and admin console will be unavailable. We are expecting these upgrades to take less than 2 hours to complete.